todesktop

Misconfiguration of Azure DevOps Pipeline
Resolved·Full outage

We have put guardrails in place so this particular issue (Azure DevOps misconfig) can’t happen again.

Tue, Nov 4, 2025, 06:46 PM
(1 month ago)
·
Affected components
Build Machines
Updates

Resolved

We have put guardrails in place so this particular issue (Azure DevOps misconfig) can’t happen again.

Tue, Nov 4, 2025, 06:46 PM

Resolved

A typo was deployed to our production Azure DevOps Pipeline. This caused builds to fail to start for all users.

The error happened early in the request cycle so it didn’t hit our alerting infra and we weren't notified. This combined with the fact that it happened during sleep hours in our timezone led to a long downtime.

Tue, Nov 4, 2025, 12:09 AM(18 hours earlier)